delorie.com/archives/browse.cgi   search  
Mail Archives: geda-help/2020/01/12/20:26:05

X-Authentication-Warning: delorie.com: mail set sender to geda-help-bounces using -f
X-Recipient: geda-help AT delorie DOT com
X-Virus-Scanned: Debian amavisd-new at smtp-vp03.sig.oregonstate.edu
Date: Sun, 12 Jan 2020 17:10:55 -0800
From: "Traylor Roger (traylor AT engr DOT orst DOT edu) [via geda-help AT delorie DOT com]" <geda-help AT delorie DOT com>
To: geda-help AT delorie DOT com
Subject: Re: [geda-help] [geda-user] xorn inport error
Message-ID: <20200113011055.GA2577@flip1.engr.oregonstate.edu>
References: <20200107175451 DOT GA3868 AT flip2 DOT engr DOT oregonstate DOT edu>
<alpine DOT DEB DOT 2 DOT 20 DOT 2001072155040 DOT 5592 AT nimbus>
<C2A782BB-3B8C-4721-8992-E06E51965198 AT ece DOT orst DOT edu>
<20200109052734 DOT C320681A6061 AT turkos DOT aspodata DOT se>
<F0129AD2-14FD-462C-BE66-D4F043708E3C AT ece DOT orst DOT edu>
<20200111045332 DOT AC2CC81A6061 AT turkos DOT aspodata DOT se>
MIME-Version: 1.0
In-Reply-To: <20200111045332.AC2CC81A6061@turkos.aspodata.se>
User-Agent: Mutt/1.5.21 (2010-09-15)
Reply-To: geda-help AT delorie DOT com
Errors-To: nobody AT delorie DOT com
X-Mailing-List: geda-help AT delorie DOT com
X-Unsubscribes-To: listserv AT delorie DOT com

Karl,
Thanks again.  Been beating on this but still have two issues.

Under Ubuntu, I find that:
export GUILE=/usr/local/guile_2.0.14/bin/guile
export GUILE_SNARF=/usr/local/guile_2.0.14/bin/guile-snarf

Are actually in:
export GUILE=/usr/local/bin/guile_2.0.14/bin/guile
export GUILE_SNARF=/usr/local/bin/guile_2.0.14/bin/guile-snarf

No problem, made those changes and I can see them take effect in
the config.log.

However, I the following directories do not exist:
/usr/local/guile_2.0.14/include/guile/2.0 
/usr/local/guile_2.0.14/lib 

As such, the make step dies at:
CPP="gcc -E" /usr/local/bin/guile_snarf -o scheme_init.x scheme_init.c -DHAVE_CONFIG_H -I. -I../..   -DLOCALEDIR=\"/opt/geda/geda-gaf-1.10.0/share/locale\"   -I./../include -I./../include/libgeda -I../..  -Wall -Werror=maybe-uninitialized   -I/usr/local/guile_2.0.13/include/guile/2.0 -pthread -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -pthread -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/include
/bin/bash: /usr/local/bin/guile_snarf: No such file or directory


I cannot find them anywhere. Any ideas? I'm in over my head...again.

Roger




On Sat, Jan 11, 2020 at 05:53:32AM +0100, karl AT aspodata DOT se wrote:
> Roger:
> > Thanks for the hint.  Tried it but to no avail.  It seems from config.log that it is
> > still attempting to use guile-2.2.  Baffled. 
> 
> Does it look like:
> 
> configure:16856: checking for guile-2.2 >= 2.0.10
> configure:16921: result: yes
> configure:17012: checking for guile
> configure:17040: result: /usr/local/guile_2.0.14/bin/guile
> configure:17061: checking for guile-snarf
> configure:17089: result: /usr/local/guile_2.0.14/bin/guile-snarf
> 
> If so, the first line is probably not bad, configure just runs
> two tests, and later in the file it shows that it is using v2.0.14.
> 
> ///
> 
> If you have guile installed somewhere, you can tell configure et.al. to 
> use it by doing e.g.:
> 
> export GUILE_CFLAGS="-I/usr/local/guile_2.0.14/include/guile/2.0 -pthread"
> export GUILE_LIBS="-L/usr/local/guile_2.0.14/lib -lguile-2.0 -latomic_ops -lgc"
> export GUILE=/usr/local/guile_2.0.14/bin/guile
> export GUILE_SNARF=/usr/local/guile_2.0.14/bin/guile-snarf
> 
> ./configure ...
> 
> ///
> 
> The cflags/libs I got from
> 
> $ pkg-config --libs /usr/local/guile_2.0.14/lib/pkgconfig/guile-2.0.pc 
> -L/usr/local/guile_2.0.14/lib -lguile-2.0 -latomic_ops -lgc
> $ pkg-config --cflags /usr/local/guile_2.0.14/lib/pkgconfig/guile-2.0.pc 
> -pthread -I/usr/local/guile_2.0.14/include/guile/2.0
> 
> Regards,
> /Karl Hammar
> 

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019