delorie.com/archives/browse.cgi   search  
Mail Archives: djgpp/2004/06/17/09:00:44

X-Authentication-Warning: delorie.com: mail set sender to djgpp-bounces using -f
From: Andris Pavenis <pavenis AT latnet DOT lv>
To: djgpp AT delorie DOT com
Subject: Re: DJGPP linux cross-compiler + GDB problem
Date: Thu, 17 Jun 2004 15:59:57 +0300
User-Agent: KMail/1.6.2
References: <A5dAc.342543$hc5 DOT 14767707 AT news3 DOT tin DOT it> <4cr2d0hkhrq5v6g597d1lie8so2u9v1js4 AT 4ax DOT com>
In-Reply-To: <4cr2d0hkhrq5v6g597d1lie8so2u9v1js4@4ax.com>
MIME-Version: 1.0
Message-Id: <200406171559.57933.pavenis@latnet.lv>
Reply-To: djgpp AT delorie DOT com

On Thursday 17 June 2004 13:15, Andrew Cottrell wrote:

> 1) Ensure that you are using the DJGPP 2.04 beta releases and NOT the
> 2.03 releases. This is because you are using XP.

For me packages built using djdev203 (revision 2) works in average much better 
under WinXP Pro rather than either of DJGPP v2.04 beta or current CVS. (at 
least on one box). For example only really working bash, which I have is
one from djgpp distribution (v2gnu/bsh204b.zip). For example bsh205bb.zip from
clio.rice.edu was unusable for running almost any configuration script
(reproducible jumps out of DPMI, not immediatelly though). Using bash from 
v2gnu/bsh204b.zip, I succefully built for example gcc-3.3.3, gcc-3.4.0, 
gdb-6.1.1 (all under WinXP)

> 3) A few days ago Andris released a test GCC 3.4. You may want to try
> this so that then you have the same version of GCC on both OS's.

It crashes rather often while compiling C++ sources, so be carefull.

> 4) I do not know how to do this, but check that GDB and Binutils both
> support the same version of Dwarf (I do not know if there are
> different versions).

For gcc-3.4.0 perhaps GDB-6.1 or newer may be needed, binutils-2.14 or 2.15
should be Ok

Andris

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019