delorie.com/archives/browse.cgi   search  
Mail Archives: djgpp/2001/06/05/15:23:29

Date: Tue, 05 Jun 2001 21:08:20 +0300
From: "Eli Zaretskii" <eliz AT is DOT elta DOT co DOT il>
Sender: halo1 AT zahav DOT net DOT il
To: "Igor Bujna" <igor DOT bujna AT maxi-tip DOT cz>
Message-Id: <2427-Tue05Jun2001210820+0300-eliz@is.elta.co.il>
X-Mailer: Emacs 20.6 (via feedmail 8.3.emacs20_6 I) and Blat ver 1.8.9
CC: djgpp AT delorie DOT com
In-reply-to: <3B1D1C1D.4667.1168398@localhost> (igor.bujna@maxi-tip.cz)
Subject: Re: Problem with debuggering
References: <3B1D1C1D DOT 4667 DOT 1168398 AT localhost>
Reply-To: djgpp AT delorie DOT com
Errors-To: nobody AT delorie DOT com
X-Mailing-List: djgpp AT delorie DOT com
X-Unsubscribes-To: listserv AT delorie DOT com

> From: "Igor Bujna" <igor DOT bujna AT maxi-tip DOT cz>
> Date: Tue, 5 Jun 2001 17:51:25 +0200
> 
> CC	= gcc
> INCLUDE	= .
> .SUFFIXES: .c .h
> CFLAGS=-g -Wall -I$(INCLUDE)
> LIBS=-lpanel -lpdcurses
> 
> OBJS	= menurt.o main.o
> 
> main:	$(OBJS)
> 	$(CC) $(OBJS) -o main $(LIBS)
> 
> %.o: %.c *.h
> 	$(CC) $(CFLAGS) $(INCLUDEDIR) -c -o $*.o $<
> 
> When i compiling the "main" program everything are OK.
> When i run this program over rhgdb still everything OK.But when i 
> go in function,which is in menurt.c a see this warning.
> "The selected breakpoint is invalid, probablythis file is not compiled 
> with debugging information or for this line is no code generated.."
> I put breakpoint on this line 	"cprintf ("%i", cislo);" 
> What i was doing bad.

Try replacing -g with -gstabs+ in CFLAGS, then recompile and relink
all of the sources, and see if that helps.

Also, does this happen for only that one line, or for any line in
menurt.c?

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019