delorie.com/archives/browse.cgi   search  
Mail Archives: djgpp/1997/08/09/14:37:29

Message-ID: <33E73F9A.1A3D@gapeach.com>
Date: Tue, 05 Aug 1997 10:58:34 -0400
From: Jacob Martin <jake AT gapeach DOT com>
Reply-To: jake AT gapeach DOT com
MIME-Version: 1.0
Newsgroups: comp.os.msdos.djgpp
Subject: Bug in DJGPP? or just a bug in my head...
NNTP-Posting-Host: ip205.iainc.net
Lines: 52
To: djgpp AT delorie DOT com
DJ-Gateway: from newsgroup comp.os.msdos.djgpp

ok...here's the deal:

I have a program that will run in gdb, and exit fine...

but, if I run it from the prompt, it gives me this:


Shutting down Allegro
Exiting due to signal SIGSEGV
General Protection Fault at eip=00007718
eax=00124204 ebx=00016000 ecx=00016800 edx=00121604 esi=00000054
edi=00000011
ebp=0010a7f0 esp=000f160c program=E:\GAME\A.EXE
cs: sel=00a7  base=82f2c000  limit=00123fff
ds: sel=00af  base=82f2c000  limit=00123fff
es: sel=00af  base=82f2c000  limit=00123fff
fs: sel=0087  base=000084e0  limit=0000ffff
gs: sel=00bf  base=00000000  limit=ffffffff
ss: sel=00af  base=82f2c000  limit=00123fff

Call frame traceback EIPs:
  0x00007718
  0x0000166a
  0x0001fbfa


now, I've checked everything...over and over and over again and
...ugh...


Anyway, when I run it from gdb...it runs! and exits normally!

BUT! if I put a breakpoint in the file and run the program....

first it stops at the breakpoint...
then I continue
it does it's stuff..
and then it says...



Program exited normally.
0x10 in ?? ()
(gdb)




What the hell?  This is crazy, and it's starting to wear off on me!
help!

Jake ...

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019