delorie.com/archives/browse.cgi   search  
Mail Archives: djgpp-workers/2003/02/10/01:14:46

Date: Mon, 10 Feb 2003 08:13:04 +0200 (IST)
From: Eli Zaretskii <eliz AT is DOT elta DOT co DOT il>
X-Sender: eliz AT is
To: djgpp-workers AT delorie DOT com
Subject: Re: djgpp: djgpp/include/string.h,strings.h
In-Reply-To: <10302100511.AA22688@clio.rice.edu>
Message-ID: <Pine.SUN.3.91.1030210081221.7932H-100000@is>
MIME-Version: 1.0
Reply-To: djgpp-workers AT delorie DOT com
Errors-To: nobody AT delorie DOT com
X-Mailing-List: djgpp-workers AT delorie DOT com
X-Unsubscribes-To: listserv AT delorie DOT com

On Sun, 9 Feb 2003, Charles Sandmann wrote:

> It seems that at least gcc 2.8.1 builds current cvs libc OK.
> 
> gcc 2.7.2.1 has some problems (does surprisingly well)
> but this is expected with a 7 year old compiler.  In particular, some
> of the new headers cause errors. 

Thanks for testring this.

> ../../../../include/libc/fsexthlp.h:32: warning: inline declaration ignored for
> function with `...'  (do we really need inline?)
> 
> ../../../../include/stdint.h:27: parse error before `__extension__'
> ../../../../include/stdint.h:37: parse error before `__extension__'

I think we should fix these errors so that the library builds with GCC 2.7.x.

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019