delorie.com/archives/browse.cgi   search  
Mail Archives: djgpp-workers/2003/02/08/07:40:50

Message-ID: <3E450859.9090508@mif.vu.lt>
Date: Sat, 08 Feb 2003 14:38:33 +0100
From: Laurynas Biveinis <laurynas DOT biveinis AT mif DOT vu DOT lt>
Organization: VU MIF
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
X-Accept-Language: lt, en, en-us
MIME-Version: 1.0
To: djgpp-workers AT delorie DOT com, Richard Dawe <rich AT phekda DOT freeserve DOT co DOT uk>
Subject: Re: Take on __solve_symlinks()
References: <3E286C07 DOT 7040200 AT mif DOT vu DOT lt> <3E2943DA DOT 523770FC AT phekda DOT freeserve DOT co DOT uk> <3E297258 DOT 50906 AT mif DOT vu DOT lt> <3E2A9396 DOT EF36FE73 AT phekda DOT freeserve DOT co DOT uk> <3E305DAB DOT 8090607 AT mif DOT vu DOT lt> <3E305D5A DOT 16693047 AT phekda DOT freeserve DOT co DOT uk> <3E386A1C DOT 9050303 AT mif DOT vu DOT lt> <3E3940F9 DOT A66C7217 AT phekda DOT freeserve DOT co DOT uk> <3E39880C DOT 4060607 AT mif DOT vu DOT lt> <3E398E01 DOT F62E2163 AT phekda DOT freeserve DOT co DOT uk>
In-Reply-To: <3E398E01.F62E2163@phekda.freeserve.co.uk>
X-OriginalArrivalTime: 08 Feb 2003 12:35:33.0238 (UTC) FILETIME=[9294E960:01C2CF6E]
Reply-To: djgpp-workers AT delorie DOT com

Richard Dawe wrote:
>>Very interesting, given that the first thing __solve_symlink does is to
>>copy __symlink_path to __real_path. I don't see how this patch could
>>make any difference, and it doesn't at my sandbox. The testcase gives
>>correct results both ways. I strongly suspect that we are testing two
>>different versions of __solve_symlinks... Maybe you could try copy
>>somewhere the directory with testsuite sources, copy here up to the date
>>CVS version of __solve_symlinks and add it to makefile ?
> 
> 
> I've just tried building with another CVS that has _no_ source changes and
> only changes to the Cygnus test suite (C++ build fixes). I just did a 'cvs
> update -dA', so it has your latest check-in for xsymlink.c ("Rearrange symlink
> loop detection"). This is my "reference" read-only tree. The test fails there
> too.

I've created separate clean DJGPP installation with CVS libc and binaries
from clio.rice.edu dated 2003-02-01 and symlink testsuite still does not
fail here. Frankly, I think I've done everything I could at this point.
Maybe it's W98 vs W2K thing? Could somebody else with W98/W2K test
tests/libc/compat/unistd/xsymlink.c to see if it fails? In any case, I'm
unable to debug it here, so I won't for now until someone gives a clue.

--
Laurynas


- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019