Mail Archives: djgpp-workers/2003/03/22/23:56:39
Eli Zaretskii wrote:
> > From: CBFalconer <cbfalconer AT yahoo DOT com>
> >
> > > > what about:
> > > >
> > > > int malloc_debug(int level, FILE *f);
> > > >
> > > > where f == NULL is the present call, and something else sets the
> > > > output file. Maybe we rename it _malloc_dbg and provide a macro:
> > > >
> > > > #define malloc_debug(i) _malloc_dbg(i, NULL)
> > >
... snip ...
>
> Perhaps just have
>
> int malloc_debug(int level);
>
> and
>
> int _malloc_debug_with_file(int level, FILE *f);
What's the difference from the above macro definition except the
name of the system function? If you want it more descriptive try
"_malloc_dbg_set_output", but I think it is excessively verbiose.
Maybe "_mallocdbgf" or "_mallocdbgcnf" for configure.
At least the principle is set. All we need is a name :-)
--
Chuck F (cbfalconer AT yahoo DOT com) (cbfalconer AT worldnet DOT att DOT net)
Available for consulting/temporary embedded and systems.
<http://cbfalconer.home.att.net> USE worldnet address!
- Raw text -