delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-developers/2002/07/14/08:44:37

Mailing-List: contact cygwin-developers-help AT cygwin DOT com; run by ezmlm
List-Subscribe: <mailto:cygwin-developers-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-developers/>
List-Post: <mailto:cygwin-developers AT cygwin DOT com>
List-Help: <mailto:cygwin-developers-help AT cygwin DOT com>, <http://sources.redhat.com/ml/#faqs>
Sender: cygwin-developers-owner AT cygwin DOT com
Delivered-To: mailing list cygwin-developers AT cygwin DOT com
Message-ID: <007a01c22b34$81dc2fe0$6132bc3e@BABEL>
From: "Conrad Scott" <Conrad DOT Scott AT dsl DOT pipex DOT com>
To: <cygwin-developers AT cygwin DOT com>
References: <002a01c22b2f$07f9bda0$6132bc3e AT BABEL> <005c01c22b33$b2e3b870$6132bc3e AT BABEL>
Subject: Re: Protect handle issue-ettes
Date: Sun, 14 Jul 2002 13:46:42 +0100
MIME-Version: 1.0
X-Priority: 3
X-MSMail-Priority: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000

Sorry: wrong mailing list: read as if posted on cygwin-patches.
Etc. etc.

----- Original Message -----
From: "Conrad Scott" <Conrad DOT Scott AT dsl DOT pipex DOT com>
To: <cygwin-developers AT cygwin DOT com>
Sent: Sunday, July 14, 2002 1:40 PM
Subject: Re: Protect handle issue-ettes


> I wrote:
> > I'm still not clear why the cygserver code disturbs this
> > mechanism so much: I wasn't getting the seg. fault on
> > the HEAD version.  I've now added calls to ProtectHandle
> > into the cygserver code, so this doesn't seem to be
> > anything to do with their (previous) omission.
>
> Just to clarify, the seg. fault also goes away w/o the debug.cc
> patch once I add the ProtectHandle calls to the cygserver code,
> but the noise is even worse.
>
> // Conrad



- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019