delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-developers/2000/04/05/15:56:57

Mailing-List: contact cygwin-developers-help AT sourceware DOT cygnus DOT com; run by ezmlm
List-Subscribe: <mailto:cygwin-developers-subscribe AT sourceware DOT cygnus DOT com>
List-Archive: <http://sourceware.cygnus.com/ml/cygwin-developers/>
List-Post: <mailto:cygwin-developers AT sourceware DOT cygnus DOT com>
List-Help: <mailto:cygwin-developers-help AT sourceware DOT cygnus DOT com>, <http://sourceware.cygnus.com/ml/#faqs>
Sender: cygwin-developers-owner AT sourceware DOT cygnus DOT com
Delivered-To: mailing list cygwin-developers AT sourceware DOT cygnus DOT com
From: Chris Faylor <cgf AT cygnus DOT com>
Date: Wed, 5 Apr 2000 15:56:39 -0400
To: cygwin-developers AT sourceware DOT cygnus DOT com
Subject: Re: mingw using wrong errno definition
Message-ID: <20000405155639.A3467@cygnus.com>
Reply-To: cygwin-developers AT sourceware DOT cygnus DOT com
Mail-Followup-To: cgf AT cygnus DOT com, cygwin-developers AT sourceware DOT cygnus DOT com
References: <200004051953 DOT MAA09781 AT cygnus DOT com>
Mime-Version: 1.0
User-Agent: Mutt/1.1.8i
In-Reply-To: <200004051953.MAA09781@cygnus.com>; from rdparker@butlermfg.com on Wed, Apr 05, 2000 at 02:52:18PM -0500

On Wed, Apr 05, 2000 at 02:52:18PM -0500, Parker, Ron wrote:
>> From: Chris Faylor [mailto:cgf AT cygnus DOT com]
>> >Index: winsup/cinstall/Makefile.in
>> >===================================================================
>> >RCS file: /cvs/src/src/winsup/cinstall/Makefile.in,v
>> >retrieving revision 1.2
>> >diff -r1.2 Makefile.in
>> >102c102
>> >< zlib/zlibcygw.a: zlib/Makefile
>> >---
>> >>zlib/libzcygw.a: zlib/Makefile
>> 
>> I don't get this one.  My version of Makefile.in doesn't have 
>> a blank line
>> before the "zlib" here.  I've changed this to $(ZLIB) anyway 
>> since that
>> is more consistent.
>
>Strange, the copy I recieved from the list does not have the extra blank
>line.  All I was changing was a typo in the name of the lib file, so I could

Oh.  I focused on the space and missed the "zlibc".

>have a make of cinstall correctly and properly build and link zlib. Your
>$(ZLIB) macro should correct this as well.

Yeah, I defined it specifically to avoid problems like this since I had
misspelled libzcygw repeatedly.  Then I didn't use it where it mattered.

>>Can you try doing a "make clean all" in the cinstall directory and see
>>if that "fixes" things?
>
>I think I did, but will verify this tonight.

If it doesn't, you're right that this is somehow picking up cygwin includes.
Try doing a "gcc -v" on one of the source files to see where it thinks it
is picking up includes.  You can also do a "gcc -E" to get the definitive
answer.

cgf

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019