delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-developers/2000/03/16/06:38:35

Mailing-List: contact cygwin-developers-help AT sourceware DOT cygnus DOT com; run by ezmlm
List-Subscribe: <mailto:cygwin-developers-subscribe AT sourceware DOT cygnus DOT com>
List-Archive: <http://sourceware.cygnus.com/ml/cygwin-developers/>
List-Post: <mailto:cygwin-developers AT sourceware DOT cygnus DOT com>
List-Help: <mailto:cygwin-developers-help AT sourceware DOT cygnus DOT com>, <http://sourceware.cygnus.com/ml/#faqs>
Sender: cygwin-developers-owner AT sourceware DOT cygnus DOT com
Delivered-To: mailing list cygwin-developers AT sourceware DOT cygnus DOT com
Message-ID: <38D0C121.9A777107@vinschen.de>
Date: Thu, 16 Mar 2000 12:10:25 +0100
From: Corinna Vinschen <corinna AT vinschen DOT de>
Reply-To: cygwin-developers AT sourceware DOT cygnus DOT com
X-Mailer: Mozilla 4.72 [en] (Windows NT 5.0; U)
X-Accept-Language: de,en
MIME-Version: 1.0
To: cygwin-developers AT sourceware DOT cygnus DOT com
Subject: Re: Yet another hanging issue.
References: <s1s66up1wg2 DOT fsf AT jaist DOT ac DOT jp> <20000314103313 DOT A15910 AT cygnus DOT com>
<s1s3dpt1o8q DOT fsf AT jaist DOT ac DOT jp> <20000314124712 DOT A19647 AT cygnus DOT com>
<s1szos03x3z DOT fsf AT jaist DOT ac DOT jp> <20000315143028 DOT A32468 AT cygnus DOT com> <s1swvn43pwn DOT fsf AT jaist DOT ac DOT jp>

Kazuhiro Fujieda wrote:
> 
> >>> On Wed, 15 Mar 2000 14:30:28 -0500
> >>> Chris Faylor <cgf AT cygnus DOT com> said:
> 
> > Sorry.  I broke a cardinal rule and checked in some code without
> > testing it.  I removed some stuff that I thought was extraneous
> > in spawn.cc.  It wasn't.
> >
> > The following patch should fix this problem.
> 
> I confirmed the problem was resolved.
> Thanks.

Hi Chris,

umm, I know, this is not what you want to hear.

The latest version has still an unresolved hanging problem.
I can reproduce the following behaviour:

Starting tcsh in TeraTerm telnet client window (via inetd as service ->
telnetd -> login) as login shell. Start a command: `ls -C' works.
Change window size, start `ls -C' again. Now the command is working
as before but it never returns to the prompt. `ps -ef' from another
shell displays:

...
  system   1001      1  -1  11:34:15 /usr/local/sbin/inetd.exe
  system   1134   1001  -1  11:52:08 /usr/local/libexec/in.telnetd
 corinna   1135   1134   2  11:52:13 /usr/bin/tcsh.exe
 corinna   1144   1135   2  11:52:19 <defunct>
...

As I mentioned, this is 100% reproducable. I tried to reproduce it
under strace control (startimg tcsh, some cmd, change win size,
start cmd via strace) but unfortunately strace hangs on starting
it already. The output file remains empty :-(

This doesn't happen with bash. Sometimes I get the feeling that 
tcsh is somewhat hard to please...

Corinna

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019