delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-developers/1998/10/01/17:01:03

From: cgf AT cygnus DOT com (Christopher Faylor)
Subject: Re: make b20alpha
1 Oct 1998 17:01:03 -0700 :
Message-ID: <19981001194053.G1607.cygnus.cygwin32.developers@cygnus.com>
References: <360E9936 DOT 7DF49B0C AT cityweb DOT de>
Mime-Version: 1.0
To: Corinna Vinschen <corinna DOT vinschen AT cityweb DOT de>,
cygwin32-developers AT cygnus DOT com

On Mon, Sep 28, 1998 at 10:05:57PM +0200, Corinna Vinschen wrote:
>Christopher Faylor wrote:
>> This seems to work around the problem (in the newlib directory):
>> 
>> ./configure -v --build=i386-pc-cygwin32 --srcdir=`pwd`
>> 
>
>Report of experience:

You'll probably notice that this problem is still in Geoffrey's
latest B20 snapshot.  I have a possible fix for the problem but
I haven't had time to test it out.

The basic problem is that, contrary to my earlier assertion,  Cygnus
does not support building in the same directory as the sources.  Our
customers are usually instructed to use a separate build directory
from the sources when making product.

So, you'll see problems like this crop up from time to time.  That's not
to say that this shouldn't work.  It is probably still in everyone's best
interest to get newlib configure working in its source directory because
net users will undoubtedly be frequently trying exactly the same thing.

Hopefully my patch (if it works) will be in the next snapshot.

-chris

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019