delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/03/25/11:54:10

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Mail-Followup-To: cygwin-apps AT cygwin DOT com
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
Date: Mon, 25 Mar 2002 11:54:08 -0500
From: Christopher Faylor <cgf AT redhat DOT com>
To: cygwin-apps AT cygwin DOT com
Subject: setup.exe problem [johnm AT falch DOT net: Re: no exec files from gcc and c++]
Message-ID: <20020325165408.GH18503@redhat.com>
Mail-Followup-To: cygwin-apps AT cygwin DOT com
Mime-Version: 1.0
User-Agent: Mutt/1.3.23.1i

--sdtB3X0nJg68CQEu
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline


--sdtB3X0nJg68CQEu
Content-Type: message/rfc822
Content-Disposition: inline

Return-Path: <cygwin-return-47177-cgf=redhat DOT com AT cygwin DOT com>
Received: from localhost.localdomain (int-mx1.corp.redhat.com [172.16.52.254])
	by lacrosse.corp.redhat.com (8.11.6/8.9.3) with ESMTP id g2PGEbi32132
	for <cgf AT redhat DOT com>; Mon, 25 Mar 2002 11:14:37 -0500
Received: from mx1.redhat.com (mx1.redhat.com [172.16.48.31])
	by localhost.localdomain (8.11.6/8.11.6) with SMTP id g2PGEbm32055
	for <cgf AT redhat DOT com>; Mon, 25 Mar 2002 11:14:37 -0500
Received: from sources.redhat.com (sources.redhat.com [209.249.29.67])
	by mx1.redhat.com (8.11.6/8.11.6) with SMTP id g2PGCIu21352
	for <cgf AT redhat DOT com>; Mon, 25 Mar 2002 11:12:18 -0500
Received: (qmail 15432 invoked by alias); 25 Mar 2002 16:14:23 -0000
Mailing-List: contact cygwin-help AT cygwin DOT com; run by ezmlm
Precedence: bulk
List-Unsubscribe: <mailto:cygwin-unsubscribe-cgf=redhat DOT com AT cygwin DOT com>
List-Subscribe: <mailto:cygwin-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin/>
List-Post: <mailto:cygwin AT cygwin DOT com>
List-Help: <mailto:cygwin-help AT cygwin DOT com>, <http://sources.redhat.com/ml/#faqs>
Sender: cygwin-owner AT cygwin DOT com
Mail-Followup-To: cygwin AT cygwin DOT com
Delivered-To: mailing list cygwin AT cygwin DOT com
Received: (qmail 15425 invoked from network); 25 Mar 2002 16:14:21 -0000
Received: from unknown (HELO zappa.falch.net) (193.69.105.131)
  by sources.redhat.com with SMTP; 25 Mar 2002 16:14:21 -0000
Received: from kahikatea.falch.net (kahikatea.falch.net [193.71.98.234])
	by zappa.falch.net (8.11.1/8.11.1/Debian 8.11.0-6) with ESMTP id g2PGEH303366
	for <cygwin AT cygwin DOT com>; Mon, 25 Mar 2002 17:14:17 +0100
Received: (from johnm AT localhost)
	by kahikatea.falch.net (8.11.6/8.11.6) id g2PGDab01865
	for cygwin AT cygwin DOT com; Mon, 25 Mar 2002 17:13:36 +0100
Date: Mon, 25 Mar 2002 17:13:36 +0100
From: John Marshall <johnm AT falch DOT net>
To: cygwin AT cygwin DOT com
Subject: Re: no exec files from gcc and c++
Message-ID: <20020325161336 DOT GA1850 AT kahikatea DOT falch DOT net>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <4 DOT 2 DOT 0 DOT 58 DOT 20020325115353 DOT 009b5930 AT mail DOT univ-reims DOT fr>
User-Agent: Mutt/1.3.27i
Organization: Falch.net
X-Spam-Status: No, hits=-5.0 required=5.0 tests=IN_REP_TO,CYGWIN,UNSUB_PAGE version=2.20

Jean-Marc Nuzillard wrote:
> g++ -c hello.cpp
> ---------> g++ not found, took some time to think to try c++

I think at least this part of your problems is due to another bug in
setup.exe 2.194.2.15.  (I've looked briefly for relevant discussion here
and on cygwin-apps and seen none -- sorry if this is already known.)

According to http://www.cygwin.com/packages/, the gcc package contains

72192 2001-06-17 22:02:45 usr/bin/c++.exe
35328 2001-06-17 22:02:45 usr/bin/c++filt.exe
72704 2001-06-17 22:02:45 usr/bin/cpp.exe
    0 2001-06-17 22:02:45 usr/bin/g++.exe link to usr/bin/c++.exe

If you look in setup.log.full I suspect you'll see that extraction of
g++.exe failed.  I suspect current setup.exe is not dealing with links
in tarball packages correctly.

One of my users alerted me to this problem in my prc-tools package
today.  Files listed as "link to [previous file in tarball]" were not
being extracted by setup.exe 2.194.2.15, and would be absent from the
resulting installation.  OTOH setup.exe 2.125.2.10 given the same
tarball extracted them correctly.

    John

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Bug reporting:         http://cygwin.com/bugs.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

--sdtB3X0nJg68CQEu--

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019