delorie.com/archives/browse.cgi   search  
Mail Archives: cygwin-apps/2002/03/21/18:41:17

Mailing-List: contact cygwin-apps-help AT cygwin DOT com; run by ezmlm
Sender: cygwin-apps-owner AT cygwin DOT com
List-Subscribe: <mailto:cygwin-apps-subscribe AT cygwin DOT com>
List-Archive: <http://sources.redhat.com/ml/cygwin-apps/>
List-Post: <mailto:cygwin-apps AT cygwin DOT com>
List-Help: <mailto:cygwin-apps-help AT cygwin DOT com>, <http://sources.redhat.com/lists.html#faqs>
Mail-Followup-To: cygwin-apps AT cygwin DOT com
Delivered-To: mailing list cygwin-apps AT cygwin DOT com
Date: Thu, 21 Mar 2002 23:41:10 +0000
Message-ID: <6835-Thu21Mar2002234111+0000-starksb@ebi.ac.uk>
X-Mailer: 21.5 (beta2) "artichoke" XEmacs Lucid (via feedmail 9-beta-7 I);
VM 7.00 under 21.5 (beta2) "artichoke" XEmacs Lucid
From: David Starks-Browning <starksb AT ebi DOT ac DOT uk>
MIME-Version: 1.0
To: cygwin-apps AT cygwin DOT com
Subject: why w32api-1.2-1 is broken in setup 2.194.2.15

I think I know why w32api-1.2-1 is broken in setup 2.194.2.15.  That
is, I don't know what bug to fix in setup, but I know what's unique
about w32api-1.2-1.tar that is causing problems.  The paths are of the
form "./usr/lib/..." instead of "usr/lib/...".  That extra "./"
shouldn't matter but it causes the problem.

Here is part of "tar jtvf w32api-1.2-1.tar.bz2":

...
drwxr-xr-x BoydE/Administrators      0 2001-12-07 14:51:10 ./usr/lib/
drwxr-xr-x BoydE/Administrators      0 2001-12-07 14:51:13 ./usr/lib/w32api/
-rw-r--r-- BoydE/Administrators 408608 2001-12-07 14:51:10 ./usr/lib/w32api/libadvapi32.a
-rw-r--r-- BoydE/Administrators   4254 2001-12-07 14:51:10 ./usr/lib/w32api/libcap.a
...

If it's re-packaged like this:

...
drwxr-xr-x BoydE/Administrators      0 2001-12-07 14:51:10 usr/lib/
drwxr-xr-x BoydE/Administrators      0 2001-12-07 14:51:13 usr/lib/w32api/
-rw-r--r-- BoydE/Administrators 408608 2001-12-07 14:51:10 usr/lib/w32api/libadvapi32.a
-rw-r--r-- BoydE/Administrators   4254 2001-12-07 14:51:10 usr/lib/w32api/libcap.a
...

(without the leading "./") then setup 2.194.2.15 installs it
properly.  At least, that does it for me.

Perhaps someone (Earnie?) with quick access to cygwin/latest/w32api on
sources.redhat.com could repack these archives in time for mirrors to
get them tonight?  I guess they should be 1.2-2?

I'm in the process of downloading all cygwin packages to check for
others with this packaging style.  But someone with access to an
existing mirror could do this more easily.  I will probably fall
asleep before my download finishes.  Assuming I have enough disk
space...

Sweet dreams.

David

- Raw text -


  webmaster     delorie software   privacy  
  Copyright 2019   by DJ Delorie     Updated Jul 2019